Welcome

M9186A PXI
Voltage/Current Source

LabVIEW G Programming Information

This help file contains the LabVIEW G programming information for the M9186A PXI Voltage/Current Source.

  • Introduction
  • Programming Examples
  • Method (VI) Reference
  • Related Documentation

© Agilent Technologies, Inc. 2010

Version 1.0


Introduction

Introduction to the AgM9186 LabVIEW Driver

The AgM9186 LabVIEW Driver allows you programmatic control for the M9186A PXI Voltage/Current Source. The Agilent M9186A PXI Voltage/Current Source has the
capability of operating in 4 quadrant (± voltage/current). Its output is based on an amplitude DAC with 16- bit resolution. This module features short circuit current protection and safety interlock, which cuts off hazardous high voltages as indicated with an LED on the front panel.

See Also:
  • Agilent M9186A product Web site
  • Block diagram
  • VI descriptions
  • Examples
  • Related documentation


M9186A Block Diagram


Scenarios and Sample Programs

Programming Examples for the AgM9360 LabVIEW Driver

The following example programs are provided to demonstrate most features in the M9186A PXI Voltage/Current Source. Each example VI has a front panel you can use to exercise the underlying VI functions.

  • High Current Source
  • High Voltage Source
  • Low Current Source
  • Low Voltage Source
  • Source Current Voltage


Agilent M9186 - High Current Source.vi

This example VI reads a few identity interface properties using GetAttributeViString VI, configure the instrument for high current source and set signal level using Output Configure VI.

It also verifies the output level using the GetLevel VI.

Agilent M9186 - High Current Source.vi


Agilent M9186 - High Voltage Source.vi

This example VI reads a few identity interface properties using GetAttributeViString VI, configure the instrument for high voltage source and other parameters such as current sense, signal level and sense resistance using Output Configure VI.

The OutputConfigureLevel VI is used to change the output level and verifies the output level using the GetLevel VI.

Agilent M9186 - High Voltage Source.vi


Agilent M9186 - Low Current Source.vi

This example VI reads a few identity interface properties using GetAttributeViString VI, configure the instrument for low current source and signal level using Output Configure VI.

It also verifies the output level using the GetLevel VI.

Agilent M9186 - Low Current Source.vi


Agilent M9186 - Low Voltage Source.vi

This example VI reads a few identity interface properties using GetAttributeViString VI, configure the instrument for low voltage source and other parameters such as current sense, signal level and sense resistance using Output Configure VI.

The OutputConfigureLevel VI is used to change the output level and verifies the output level using the Get Level VI.

Agilent M9186 - Low Voltage Source.vi


Agilent M9186 - Source Current Voltage.vi

This example VI uses Output Configure VI to configure the instrument for manually selected parameters such as output functionality (i.e. High Voltage/Low Voltage/High Current /Low Current source), sense enable and output signal level.

Agilent M9186 - Source Current Voltage.vi


Methods

This section provides detailed descriptions of the Agilent M9186A LabVIEW driver VIs.

See Also:
  • Programming examples
  • M9186A block diagram


Agilent M9186.lvlib:GetLevel.vi

The VI returns the present output level setting on the instrument.

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

idbl

Level

Returns the current value of output level setting on the instrument.


Agilent M9186.lvlib:GetAttributeViBoolean.vi

Gets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

SENSE_ENABLE

TRACE_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9186.lvlib:GetAttributeViInt32.vi

Gets an Int32 attribute from the instrument driver.

The following Attributes are supported:

OUTPUT_FUNCTION

SENSE_RESISTANCE

SLOT_NUMBER

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9186.lvlib:GetAttributeViString.vi

Gets a String attribute from the instrument driver.

The following Attributes are supported:

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_VENDOR

SPECIFIC_DRIVER_REVISION

LOGICAL_NAME

IO_RESOURCE_DESCRIPTOR

DRIVER_SETUP

SUPPORTED_INSTRUMENT_MODELS

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

SERIAL_NUMBER

BOARD_REVISION

FPGA_REVISION

BASE_DRIVER_REVISION

CALIBRATION_DATE

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

ci32

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


Agilent M9186.lvlib:SetAttributeViBoolean.vi

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

SENSE_ENABLE

TRACE_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cu32

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

cbool

AttributeValue (Off)

The value to which to set the property.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Output Configure.vi

Configures, and then applies, the function and signal level, enables/disables sensing, and selects the indicated sense resistor if the function is Low Voltage or High Voltage (see SenseResistance parameter help for more). Otherwise for the other functions, the SenseResistance parameter is ignored.

Agilent M9186.lvlib:Output Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

Function (Low Voltage)

The desired function. One of: Low Voltage, High Voltage, Low Current, or High Current.

cdbl

Level

The desired output level, this will be immediately output. The range of values varies by function as follows: Low Voltage: -16.0 V to + 16.0 V; typical increment 0.00060984 V. High Voltage: -10.0 V to + 100.0 V; typical increment 0.00335182 V. Low Current: -20.0 mA to +20.0 mA; typical increment 0.03067485 mA. High Current: -200.0 mA to +200.0 mA; typical increment varies by signal range, see the level property/property for those values.

cbool

SenseEnable (Off)

Enables/Disables the switch that goes to the "SENSE" connection. When enabled, an external voltmeter can be connected to the "SENSE" connector to monitor the voltage across the sense resistor.

ci32

SenseResistance (Ohms0)

Sets the sense resistor. This parameter is used ONLY for Low Voltage and High Voltage functions. For other functions, this parameter is ignored. For High Voltage, only 0 Ohms or 100 Ohms are allowed. For Low Voltage, the allowable settings are 0, 100, 1000, and 10,000 Ohms.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:OutputConfigureLevel.vi

Configures, and then applies, the desired signal level for the output function.

The allowable range for the level varies by functions as follows:

Low Voltage : range is -16.0V to 16.0V, High Voltage : range is -10.0V to 100.0V

Low Current : range is -20.0 mA to 20.0 mA,High Current: range is -200.0 mA to 200.0 mA

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cdbl

Level

The desired output level, this will be immediately output. The range of values varies by function as follows: Low Voltage: -16.0 V to + 16.0 V; typical increment 0.00060984 V. High Voltage: -10.0 V to + 100.0 V; typical increment 0.00335182 V. Low Current: -20.0 mA to +20.0 mA; typical increment 0.03067485 mA. High Current: -200.0 mA to +200.0 mA; typical increment varies by signal range, see the level property/property for those values.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Reset.vi

Places the instrument in a known state. The output is disconnected, no function is selected, level is set to 0.0, and SenseEnable is Off.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Revision Query.vi

Retrieves revision information from the instrument.

Agilent M9186.lvlib:Revision Query.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

istr

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.

istr

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Error Message.vi

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Agilent M9186.lvlib:Error Message.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ci32

Error Code

Instrument driver status code.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Error Message

Instrument driver error message.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.


Agilent M9186.lvlib:VI Tree.vi

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.

Agilent M9186.lvlib:VI Tree.vi


Agilent M9186.lvlib:Close.vi

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Initialize.vi

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

cstr

resource string

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:Initialize With Options.vi

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Agilent M9186.lvlib:Initialize With Options.vi

cstr

resource string

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Agilent M9186.lvlib:IVI Error Converter.vi

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Agilent M9186.lvlib:IVI Error Converter.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ci32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cstr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

IVI error code (0)

Error code returned from an IVI instrument driver operation.

cu32

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ii32

            code

    The code input identifies the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    istr

            source

    The source string describes the origin of the error or warning.

    The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iu32

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None


Related Documentation

To access documentation related to the M9186A PXI Voltage/Current Source, use one of the following methods:

  • Browse the product CD
  • Browse the Manuals
  • Go to the product web site (www.agilent.com/find/M9186A) and browse the Manuals:
  • Start > Programs > Agilent > ProductModel: Provides links to all product documentation except for the IVI driver documentation
  • Start > Programs > Agilent IVI Drivers > ProductModel: Provides link to the product IVI driver help system
  • In context to your workflow. Click here for details.


Documentation Access